Inter AS Option B MP eBGP/VPNv4/VPNv6 eBGP Between ASBRs

Posted by

Inter AS Option B MP eBGP/VPNv4/VPNv6  eBGP Between ASBRs

The ASBR are the provider edge devices for communicating routes over the inter-as links between the service provider networks.

  • ASBRs have eBGP VPNv4/VPNv6 sessions between them.
  • ASBR does not have to maintain VRF tables. Disable the RT filtering check
  • One physical and logical interface between the ASBRs
  • One VPNv4/VPNv6  session between the ASBR to carry multiple customer routes over the inter as link
  • Common RD/RT between the SP network
  • Next-hop-self on each ASBR for iBGP session toward PE.
  • 3 LSP from one PE to another PE
  • Traffic between the ASBR is label switched.

 

INTERAS

AS10 is ASR9K (XR) and AS20 is IOS/IOS-XE platform

CONTROL PLANE VERIFICATION

  • CE1 advertising IPv4 and IPv6 prefixes via OSPFv2 and OSPFv3 to PE1.
  • PE1 receives the route and place in the VRF abc. Add RD to make the route unique.
  • Assigns VPN label for CE1 received routes. Also its redistribute the routes in PE1 BGP  address family ipv4 and ipv6 vrf abc.

 

RP/0/0/CPU0:PE1#sh route vrf abc
Tue Jan  2 20:36:42.776 UTC
Gateway of last resort is not set
O    1.0.0.1/32 [110/2] via 1.1.21.1, 1d23h, GigabitEthernet0/2/0/3

 

RP/0/0/CPU0:PE1#sh route vrf abc ipv6
Tue Jan  2 20:42:22.483 UTC
Gateway of last resort is not set
O E2 2000:ab7:120::1/128
[110/20] via fe80::5205:ff:fe15:1, 01:18:19, GigabitEthernet0/2/0/3

 

vrf abc
address-family ipv4 unicast
import route-target
9.0.0.23:10
8.0.0.31:20
!
export route-target
9.0.0.2:10
!
!
address-family ipv6 unicast
import route-target
8.0.0.31:20
8.0.0.3:20
!
export route-target
9.0.0.2:10
!
!

CE-PE

router ospf 211
vrf abc
redistribute bgp 10
address-family ipv4
area 0
interface GigabitEthernet0/2/0/3
!

PE BGP :

router bgp 10
bgp router-id 9.0.0.1
address-family ipv4 unicast
!
address-family vpnv4 unicast
!
address-family ipv6 unicast
!
address-family vpnv6 unicast
!
neighbor 9.0.0.11
remote-as 10
update-source Loopback0
address-family ipv4 unicast
!
address-family vpnv4 unicast
!
address-family vpnv6 unicast
!

vrf abc
rd 10:31
address-family ipv4 unicast
redistribute ospf 211 match internal external
!
address-family ipv6 unicast
redistribute ospfv3 211 match internal external
!

  • PE1 advertise the CE1 route to ASBR1 over the MP-iBGP with the next-hop as PE1. The route advertised as a VPNv4 routes (RD:1.0.0.1/32) and VPNv6 routes (RD:2000:ab7:120::1/128) along with RT export. Also assigns a VPN Label.

 

RP/0/0/CPU0:PE1#sh bgp vpnv4 unicast rd 10:31 1.0.0.1/32
Tue Jan  2 20:44:04.196 UTC
BGP routing table entry for 1.0.0.1/32, Route Distinguisher: 10:31

Versions:
Process           bRIB/RIB  SendTblVer
Speaker                230         230
Local Label: 24027  >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>. Local Label

Last Modified: Jan  2 18:45:45.300 for 01:58:18
Paths: (1 available, best #1)
Advertised to peers (in unique update groups):
9.0.0.6       9.0.0.5
Path #1: Received by speaker 0
Advertised to peers (in unique update groups):
9.0.0.6       9.0.0.5
Local
1.1.21.1 from 0.0.0.0 (9.0.0.2)
Origin incomplete, metric 2, localpref 100, weight 32768, valid, redistributed, best, group-best, import-candidate
Received Path ID 0, Local Path ID 1, version 230
Extended community: OSPF route-type:0:1:0x0 OSPF router-id:9.0.0.2 RT:9.0.0.2:10

 

RP/0/0/CPU0:PE1#sh bgp vpnv6 unicast  rd 10:31 2000:ab7:120::1/128
Tue Jan  2 20:45:09.582 UTC

BGP routing table entry for 2000:ab7:120::1/128, Route Distinguisher: 10:31
Versions:
Process           bRIB/RIB  SendTblVer
Speaker                 15          15
Local Label: 24028  >>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>>. Local Label

Last Modified: Jan  2 19:24:03.300 for 01:21:06
Paths: (1 available, best #1)
Advertised to update-groups (with more than one peer):
0.1
Path #1: Received by speaker 0
Advertised to update-groups (with more than one peer):
0.1
Local
fe80::5205:ff:fe15:1 from 0.0.0.0 (9.0.0.2)
Origin incomplete, metric 20, localpref 100, weight 32768, valid, redistributed, best, group-best, import-candidate
Received Path ID 0, Local Path ID 1, version 15
Extended community: OSPF route-type:0:5:0x1 OSPF router-id:9.0.0.2 RT:9.0.0.2:10

 

RP/0/0/CPU0:PE1#sh bgp vpnv4 unicast neighbors 9.0.0.5 advertised-routes
Tue Jan  2 20:46:34.576 UTC
Network            Next Hop        From            AS Path
Route Distinguisher: 10:31
1.0.0.1/32       9.0.0.2       Local           ?
RP/0/0/CPU0:PE1#sh bgp vpnv6 unicast neighbors 9.0.0.5 advertised-routes
Tue Jan  2 20:47:22.833 UTC
Network            Next Hop        From            AS Path
Route Distinguisher: 10:31
2000:ab7:120::1/128
9.0.0.2       Local           ?

  • ASBR1 has RT filter check disable ( retain route-target all) and imports all the VPNv4 and VPNv6 routes form PE1.

 

router bgp 10
bgp router-id 9.0.0.111

address-family vpnv4 unicast
retain route-target all
!
address-family vpnv6 unicast
retain route-target all
!

NOTE : “retain route-target all”  in (XR) and “no bgp default route-target filter “ in (IOS/IOS-XE) is important as the ASBR device are not route-reflector ad they do not have any VRF with RT route-target configured. So they will implicitly drop the routing updates sent to     them from the route-reflector.

This is a expected behaviour as IOS and IOS-XR tend optimise the routing table information and drop the updates for these vrf with RT which are not locally configured.

  • ASBR 1 has an VPNv4/VPNv6  eBGP session towards ASBR 2. ASBR1 advertise VPNv4/VPNv6  routes belongs to CE1  to ASBR 2 with a new VPN label for CE1 loopback. ASBR 2 has RT filter check disable hence imports the routes from ASBR1.

 

router bgp 20
no bgp default route-target filter >>>>>>>>>

  • ASBR 2 has next-hop-self configured towards the PE2. When the VPNv4/VPNv6  and VPNv6 routes are advertised to PE2, ASBR2 replace the next-hop (originally ASBR1) to itself. ASBR2 assigns a new VPN label when advertising the CE1 VPNv4/VPNv6 routes to PE2.

 

address-family vpnv4
neighbor 1.2.7.7 activate
neighbor 1.2.7.7 send-community both
neighbor 8.0.0.61 activate
neighbor 8.0.0.61 send-community both
  neighbor 8.0.0.61 next-hop-self  >>>>>>>>>>>>>>>> NEXT-HOP-SELF
exit-address-family

!
address-family vpnv6
neighbor 1.2.7.7 activate
neighbor 1.2.7.7 send-community both
neighbor 8.0.0.61 activate
neighbor 8.0.0.61 send-community both
  neighbor 8.0.0.61 next-hop-self >>>>>>>>>>>>>>>> NEXT-HOP-SELF
exit-address-family

  • Once the PE2 receives the CE1 prefix, it does lookup based on the RT export assigned by VRF on PE1 and places the routes in the matching VRF with import RT on PE2.

 

vrf definition abc
rd 20:31
route-target export 8.0.0.31:20
route-target import 8.0.0.3:20
route-target import 9.0.0.2:10
!
address-family ipv4
exit-address-family
!
address-family ipv6
exit-address-family
!

  • Since PE1 and CE1 are running OSPFv2 and OSPFv3, the BGP route is redistributed into OSPF and is sent it along with the CE2 on the interface that is assigned to the VRF, where route is present.

 

router ospfv3 20
!
address-family ipv6 unicast vrf abc
redistribute bgp 20
exit-address-family

router ospf 20 vrf abc
redistribute bgp 20 subnets

 

PE1#sh ip route vrf abc
Load for five secs: 0%/0%; one minute: 0%; five minutes: 0%
No time source, *21:19:56.125 UTC Tue Jan 2 2018

Routing Table: abc

Gateway of last resort is not set

B        1.0.0.1/32 [200/0] via 8.0.0.8, 01:37:08

 

PE1#sh ipv6 route vrf abc

Load for five secs: 0%/0%; one minute: 0%; five minutes: 0%
No time source, *21:21:16.347 UTC Tue Jan 2 2018
IPv6 Routing Table – abc – 9 entries

B   2000:ab7:120::1/128 [200/0]

via 8.0.0.8%default, indirectly connected

  • In order to work the Forwarding plane we need to configure  a static route

 

RP/0/0/CPU0:ASBR1#sh running-config router static

router static
address-family ipv4 unicast
8.0.1.2/32 GigabitEthernet0/2/0/2

DATA PLANE VERIFICATION :

  • Traceroute from CE2 to CE1  for IPv4 prefix

CE2# traceroute  1.0.0.1 source lo0
Type escape sequence to abort.
Tracing the route to 1.0.0.1
VRF info: (vrf in name/id, vrf out name/id)

1 1.2.31.31 3 msec 3 msec 3 msec
2 9.3.4.4 [MPLS: Labels 27/37 Exp 0] 15 msec 14 msec 15 msec
3 9.4.8.8 [MPLS: Label 37 Exp 0] 20 msec 14 msec 27 msec
4 1.2.7.7 [MPLS: Label 24023 Exp 0] 25 msec 18 msec 21 msec
5 8.0.7.1 [MPLS: Labels 24000/24027 Exp 0] 20 msec 18 msec 21 msec
6 8.0.2.2 [MPLS: Label 24027 Exp 0] 21 msec 18 msec 21 msec
7 1.1.21.1 20 msec *  15 msec

  • Traceroute from CE1 to CE2  for IPv6 prefix

CE1#traceroute 2000:ab7:120::21
Type escape sequence to abort.
Tracing the route to 2000:ab7:120::21

1 2000:ab7:120:121::21 2 msec 1 msec 2 msec
2  *  *  *
3  *  *  *
4 ::FFFF:9.2.7.8 [MPLS: Label 64 Exp 0] 15 msec 16 msec 15 msec
5 ::FFFF:8.0.8.4 [MPLS: Labels 20/47 Exp 0] 15 msec 32 msec 33 msec
6 2000:ab7:120:231::31 [MPLS: Labels 0/47 Exp 0] 23 msec 20 msec 22 msec
7 2000:ab7:120:231::31 [MPLS: Labels 0/47 Exp 0] 21 msec 20 msec 23 msec
8 2000:ab7:120:231::21 19 msec 14 msec 14 msec

STEP 1 : Hop 1 CE2 :  [ 1 1.2.31.31 3 msec 3 msec 3 msec]

CE2#sh ip route

Load for five secs: 0%/0%; one minute: 0%; five minutes: 0%
Time source is NTP, .21:36:02.822 UTC Tue Jan 2 2018
Gateway of last resort is not set

1.0.0.0/8 is variably subnetted, 9 subnets, 2 masks
O E2     1.0.0.1/32 [110/1] via 1.2.31.31, 01:52:33, GigabitEthernet0/1

STEP 2 : HOP 2 at PE2  [2  9.3.4.4 [MPLS: Labels 27/37 Exp 0] 15 msec 14 msec 15 msec]

PE2#sh bgp vrf abc vpnv4 unicast 1.0.0.1/32
Load for five secs: 0%/0%; one minute: 0%; five minutes: 0%
No time source, *21:37:44.974 UTC Tue Jan 2 2018
BGP routing table entry for 20:31:1.0.0.1/32, version 452
Paths: (1 available, best #1, table BLUE)
Not advertised to any peer
Refresh Epoch 2
10, imported path from 10:31:1.0.0.1/32 (global)
8.0.0.8 (metric 30) (via default) from 8.0.0.61 (8.0.0.61)
Origin incomplete, metric 0, localpref 100, valid, internal, best
Extended Community: RT:9.0.0.2:10 OSPF RT:0.0.0.0:1:0
OSPF ROUTER ID:9.0.0.2:0
Originator: 8.0.0.8, Cluster list: 8.0.0.61
   mpls labels in/out nolabel/37  >>>>>>>>>>>>>>>>>>>>>>>>>>> BGP LABEL VPNv4
rx pathid: 0, tx pathid: 0x0

 

PE2#sh bgp vrf abc vpnv6 unicast  2000:ab7:120::1/128
Load for five secs: 1%/0%; one minute: 0%; five minutes: 0%
No time source, *21:39:18.538 UTC Tue Jan 2 2018
BGP routing table entry for [20:31]2000:ab7:120::1/128, version 13
Paths: (1 available, best #1,   Refresh Epoch 1
10, imported path from [10:31]2000:ab7:120::1/128 (global)
::FFFF:8.0.0.8 (metric 30) (via default) from 8.0.0.61 (8.0.0.61)
Origin incomplete, metric 0, localpref 100, valid, internal, best
Extended Community: RT:9.0.0.2:10 OSPF RT:0.0.0.0:5:1
OSPF ROUTER ID:9.0.0.2:0
Originator: 8.0.0.8, Cluster list: 8.0.0.61
mpls labels in/out nolabel/67  >>>>>>>>>>>>>>>>>>>>>>>>>>> BGP LABEL VPNv6      rx pathid: 0, tx pathid: 0x0

 

PE2#sh bgp vrf abc vpnv4 unicast labels
Load for five secs: 0%/0%; one minute: 0%; five minutes: 0%
No time source, *21:40:21.814 UTC Tue Jan 2 2018
Network          Next Hop      In label/Out label
Route Distinguisher: 20:31 (abc)
1.0.0.1/32     8.0.0.8       nolabel/37

PE31#sh bgp vrf abc vpnv6 unicast labels
Load for five secs: 0%/0%; one minute: 0%; five minutes: 0%
No time source, *21:41:16.272 UTC Tue Jan 2 2018

Network          Next Hop      In label/Out label
Route Distinguisher: 20:31 (abc)
2000:ab7:120::1/128
::FFFF:8.0.0.8
nolabel/67

Next Hop 8.0.0.8. Exit interface g2

PE2#sh ip route 8.0.0.8
Load for five secs: 0%/0%; one minute: 0%; five minutes: 0%
No time source, *21:42:42.935 UTC Tue Jan 2 2018

Routing entry for 8.0.0.8/32
Known via “isis”, distance 115, metric 30, type level-1
Redistributing via isis 20
Last update from 9.3.4.4 on GigabitEthernet2, 22:50:10 ago
Routing Descriptor Blocks:
* 9.3.4.4, from 8.0.0.8, 22:50:10 ago, via GigabitEthernet2
Route metric is 30, traffic share count is 1
Repair Path: 8.0.0.78, via MPLS-Remote-Lfa2
Transport Label 27.

 

PE2#sh mpls forwarding-table 8.0.0.8
Load for five secs: 0%/0%; one minute: 0%; five minutes: 0%
No time source, *21:43:41.774 UTC Tue Jan 2 2018
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
28         27         8.0.0.8/32     0             Gi2        9.3.4.4

 

PE2#sh mpls ldp bindings

lib entry: 8.0.0.8/32, rev 14
local binding:  label: 28
remote binding: lsr: 8.0.0.4:0, label: 27 >>>>>>>>>>>>> Outgoing Label
remote binding: lsr: 8.0.0.3:0, label: 22

IPV4 PING CE2 to CE1

Capture

STEP 3 : HOP 3 P Router  [2 9.3.4.4 [MPLS: Labels 27/37 Exp 0] 15 msec 14 msec 15 msec]

P#sh mpls forwarding-table
Load for five secs: 0%/0%; one minute: 0%; five minutes: 0%
Time source is NTP, *21:49:02.500 UTC Tue Jan 2 2018

Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
27         Pop Label  8.0.0.8/32     2269570       Gi5        9.4.8.8

 

P #sh mpls ldp bindings

lib entry: 8.0.0.8/32, rev 36
local binding:  label: 27
remote binding: lsr: 8.0.0.8:0, label: imp-null

STEP 4 : HOP 3 ASBR1 [3 9.4.8.8 [MPLS: Label 37 Exp 0] 20 msec 14 msec 27 msec]

ASBR2#sh bgp vpnv4 unicast al 1.0.0.1/32
Load for five secs: 0%/0%; one minute: 0%; five minutes: 0%
No time source, *21:55:25.993 UTC Tue Jan 2 2018
BGP routing table entry for 10:31:1.0.0.1/32, version 151
Paths: (1 available, best #1, no table)
Advertised to update-groups:
15
Refresh Epoch 1
10
1.2.7.7 (via default) from 1.2.7.7 (9.0.0.71)
Origin incomplete, localpref 100, valid, external, best
Extended Community: RT:9.0.0.2:10 OSPF RT:0.0.0.0:1:0
OSPF ROUTER ID:9.0.0.2:0
mpls labels in/out 37/24023 >>>>>>>>>>>>>>>>>>>>>>>>>>>>> Label 37 swapped with BGP label 24023
rx pathid: 0, tx pathid: 0x0

 

ASBR2#sh bgp vpnv4 unicast all labels
Load for five secs: 1%/0%; one minute: 0%; five minutes: 0%
No time source, *21:58:26.567 UTC Tue Jan 2 2018
Network          Next Hop      In label/Out label
Route Distinguisher: 10:31
1.0.0.1/32     1.2.7.7     37/24023

Between ASBR 1 and ASBR 2 MPLS is not enabled. eBGP VPNv4 is responsible for label distribution.

ASBR2#sh mpls interfaces
Load for five secs: 1%/0%; one minute: 0%; five minutes: 0%
No time source, *21:59:19.259 UTC Tue Jan 2 2018
Interface              IP            Tunnel   BGP Static Operational
GigabitEthernet2       Yes (ldp)     No       No  No     Yes
GigabitEthernet3       Yes (ldp)     No       No  No     Yes
GigabitEthernet4       No            No       Yes No     Yes

 

ASBR2#sh mpls forwarding-table interface g4
Load for five secs: 0%/0%; one minute: 0%; five minutes: 0%
No time source, *22:01:09.507 UTC Tue Jan 2 2018
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
37         24023      10:31:1.0.0.1/32    1290          Gi4        1.2.7.7

 

STEP 5 : HOP 5 at ASBR 1 [ 4 1.2.7.7 [MPLS: Label 24023 Exp 0] 25 msec 18 msec 21 msec]

RP/0/0/CPU0:ASBR1#sh bgp vpnv4 unicast rd 10:31 1.0.0.1/32
Tue Jan  2 22:05:00.214 UTC
BGP routing table entry for 1.0.0.1/32, Route Distinguisher: 10:31
Versions:
Process           bRIB/RIB  SendTblVer
Speaker                114         114
Local Label: 24023
Last Modified: Jan  2 19:02:25.210 for 03:02:35
Paths: (2 available, best #1)
Advertised to peers (in unique update groups):
9.2.7.8
Path #1: Received by speaker 0
Advertised to peers (in unique update groups):
9.2.7.8
Local
9.0.0.2 (metric 3) from 9.0.0.5 (9.0.0.2)
Received Label 24027
Origin incomplete, metric 2, localpref 100, valid, internal, best, group-best, import-candidate, not-in-vrf
Received Path ID 0, Local Path ID 1, version 114
Extended community: OSPF route-type:0:1:0x0 OSPF router-id:9.0.0.2 RT:9.0.0.2:10
Originator: 9.0.0.2, Cluster list: 9.0.0.5

 

RP/0/0/CPU0:ASBR1#sh bgp vpnv4 unicast labels
Status codes: s suppressed, d damped, h history, * valid, > best
i – internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i – IGP, e – EGP, ? – incomplete
Network            Next Hop        Rcvd Label      Local Label
Route Distinguisher: 10:31
*>i1.0.0.1/32       9.0.0.2       24027           24023

 

RP/0/0/CPU0:ASBR1#sh route 9.0.0.2
Tue Jan  2 22:08:18.881 UTC
Routing entry for 9.0.0.2/32
Known via “ospf 10”, distance 110, metric 3, type intra area
Installed Dec 31 05:25:53.679 for 2d16h
Routing Descriptor Blocks
8.0.7.1, from 9.0.0.2, via GigabitEthernet0/2/0/1
Route metric is 3
No advertising protos.

 

RP/0/0/CPU0:ASBR1#sh mpls forwarding
Tue Jan  2 22:07:42.383 UTC
Local  Outgoing    Prefix             Outgoing     Next Hop        Bytes
Label  Label       or ID              Interface                    Switched

24003  24000       9.0.0.2/32       Gi0/2/0/1    8.0.7.1     16438

 

STEP 6 : HOP 5 P Router [ 5 8.0.7.1 [MPLS: Labels 24000/24027 Exp 0] 20 msec 18 msec 21 msec ]

RP/0/0/CPU0:P1#sh route 9.0.0.2
Tue Jan  2 22:10:43.541 UTC
Routing entry for 9.0.0.2/32

Known via “ospf 10”, distance 110, metric 2, type intra area
Installed Dec 31 05:25:53.438 for 2d16h
Routing Descriptor Blocks
8.0.2.2, from 9.0.0.2, via GigabitEthernet0/2/0/5
Route metric is 2
No advertising protos.

 

RP/0/0/CPU0:P1#sh mpls forwarding
Tue Jan  2 22:10:18.962 UTC
Local  Outgoing    Prefix             Outgoing     Next Hop        Bytes
Label  Label       or ID              Interface                    Switched

24000  Pop         9.0.0.2/32       Gi0/2/0/5    8.0.2.2     2864258

 

STEP 7 : HOP 6 PE1 Router [ 6 8.0.2.2 [MPLS: Label 24027 Exp 0] 21 msec 18 msec 21 msec]

RP/0/0/CPU0:PE1#sh bgp vpnv4 unicast rd 10:31 1.0.0.1/32
Tue Jan  2 22:13:04.910 UTC
BGP routing table entry for 1.0.0.1/32, Route Distinguisher: 10:31
Versions:

Process           bRIB/RIB  SendTblVer
Speaker                230         230
Local Label: 24027
Last Modified: Jan  2 18:45:45.300 for 03:27:19
Paths: (1 available, best #1)
Advertised to peers (in unique update groups):
9.0.0.6       9.0.0.5
Path #1: Received by speaker 0
Advertised to peers (in unique update groups):
9.0.0.6       9.0.0.5
Local
1.1.21.1 from 0.0.0.0 (9.0.0.2)
Origin incomplete, metric 2, localpref 100, weight 32768, valid, redistributed, best, group-best, import-candidate
Received Path ID 0, Local Path ID 1, version 230
Extended community: OSPF route-type:0:1:0x0 OSPF router-id:9.0.0.2 RT:9.0.0.2:10

 

RP/0/0/CPU0:PE1#sh route vrf BLUE 1.0.0.1/32
Tue Jan  2 22:12:44.302 UTC
Routing entry for 1.0.0.1/32
Known via “ospf 211”, distance 110, metric 2, type intra area
Installed Dec 31 20:49:33.001 for 2d01h
Routing Descriptor Blocks
1.1.21.1, from 1.0.0.1, via GigabitEthernet0/2/0/3
Route metric is 2
No advertising protos.

 

Advertisements

2 comments

  1. Hello Sabyasachi,
    Its nice explanation ,I have one query.
    As per my understanding I think VPN label is generated by BGP when we redistribute vrf in bgp address family.
    Here on ASBR2 , I guess no vrf configured ,still bgp generating new VPN label.
    Please enlighten me exactly when VPN label is generated.

    Thanks,

    Liked by 2 people

    1. As per Inter AS Option B, we have VPNv4 family enabled between two ASBR’s eBGP. So VPNv4 family retain the RD value advertising from ASBR1 to ASBR2. So we don’t need VRF in it.

      Liked by 2 people

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out /  Change )

Google+ photo

You are commenting using your Google+ account. Log Out /  Change )

Twitter picture

You are commenting using your Twitter account. Log Out /  Change )

Facebook photo

You are commenting using your Facebook account. Log Out /  Change )

w

Connecting to %s